Overview
This article provides the steps for confirming that the Brooktrout dependency is in place and solutions to be able to start the FaxMaker Fax Server service when the "Error: 1075 the dependency service does not exist or has been marked for deletion" appears.
Diagnosis
The following error message will be seen:
Error: 1075 the dependency service does not exist or has been marked for deletion
Solution
Verify the dependencies assigned to the FaxMaker Fax Server service
- Go to Start > Run and type
services.msc
- Right-click the FaxMaker Fax Server service and select Properties.
- Select the Dependencies tab.
In the first box, you should see Brooktrout Boston Host Service and MSMQ as seen in the screenshot below:
- Verify these two services exist and are listed in the service.msc. MSMQ is a prerequisite and has not been an issue historically. If the Brooktrout Boston Host Service is not present, a reboot required to complete the removal of the drivers.
- After the reboot, start the FaxMaker Fax Server service. If the service starts, verify faxes are working. If the service does not start and continues to give the same error or possibly gives error 1068, follow the solutions listed below.
Solution #1
If the Brooktrout drivers are a requirement for your faxing, installing or reinstalling the Brooktrout drivers will get the drivers installed for use again.
Solution #2
If you do not wish to uninstall the Brooktrout drivers, follow the steps in removing the Brooktrout dependency from the FaxMkaer Fax Server service"to remove the dependency and allow the service to start.
Confirmation
Using one of the solutions listed above, you will be able to start the FaxMaker Fax Server service and resume/begin faxing.