Overview
This article provides the details on the Your license key is invalid. error, its root cause, and the steps to resolve it.
Diagnosis
This error appears when attempting to run FaxMaker Configuration Wizard. There are cases when it may or may not appear visually. It may present itself after the initial installation even after accepting the license key by showing 0 days left till expiration instead of the actual error.
This error occurs when the FaxMaker installation is unable to validate the key to GFI Servers as the fmdb_rul.mdb
does not contain the key value.
Solution
Note: The customer can perform steps 1 to 3, and the fmdb_rul.mdb
can be attached to the ticket for modification instead of being performed in a remote session.
-
Stop the GFI FaxMaker Fax Server service.
-
Run the command prompt and navigate to
C:\Program Files (x86)\GFI\FaxMaker\data\databases\
.Note: The installation directory may vary based on settings specified by the customer. -
Copy the
fmdb_rul.mdb
file to a machine with MS Access. -
Open
fmdb_rul.mdb
. -
Open the table
tb_general
. -
Find the
IFM_Reg_Key
ID, and add the product key into the value field. -
Send the file back to the customer's FaxMaker server (or attach the modified
fmdb_rul.mdb
to the ticket). -
Place the file in
C:\Program Files (x86)\GFI\FaxMaker\data\databases\
.Note: The installation directory may vary based on settings specified by the customer. -
Start GFI FaxMaker Fax Server service.
Confirmation
Start and follow the FaxMaker Configuration Wizard. The error will not appear as you run the wizard.