Overview
When installing the GFI FaxMaker client, the 'FaxMaker' printer is not installed. The printer is not visible in the ‘Printers and Faxes’ (or 'Devices and Printers') window.
Environment
- GFI FaxMaker
- All Supported Environments
Root Cause
This issue can be caused by one of the following:
- This issue will occur if the name of the printer being installed, in this case, the ‘FaxMaker’ printer, is the same as that of an existing shared name. This will cause a conflict and will not allow the GFI FaxMaker printer driver to be installed successfully.
- New Microsoft security policies within Windows 7 and later prevent the gfimntr.dll or gfimntr_x64.dll file from writing into the ..\Windows\System32 folder during the driver install process.
- Microsoft security policies are configured to forbid the installation of unsigned drivers.
Resolution
Solution #1
In order to install the GFI FaxMaker printer driver, you need to ensure that no shared name exists as ‘FaxMaker’. Also, confirm that there are no other printers using the name 'FaxMaker'.
NOTE: You can confirm shares in use by running the net share
command from the command prompt. This will provide a list of shares available on the machine.
Solution #2 (Applies to Windows 7 or later)
- From the <..\GFI\FaxMaker Client> folder, copy the gfimntr_64.dll (for 64-bit) or the gfimntr.dll (for 32-bit) file to the <..\Windows\System32> folder.
- Navigate to Control Panel, choose Printers, then select the 'FaxMaker' printer (if present) and delete.
- Select the File > Server Properties... > Drivers tab.
- Find 'FaxMaker' within the list of drivers.
- Click the Remove... button.
- Choose Remove driver and driver package.
- Stop and restart the Print Spooler service.
- From the root of the ..\GFI\FaxMaker Client installation folder, double-click fmprinter_install.cmd to re-install the FaxMaker printer.
- Click 'Install this driver software anyway' if prompted with the unsigned driver dialog.
- Check the Printers section within the Control Panel and make sure that the 'FaxMaker' printer is now present. Verify that it is set to the default printer.
- Open the Windows Task Manager, select to Show processes from all users, then check for the existence of a process named splwow64.exe. If it exists, end the process.
- Stop and restart the Print Spooler service.
Solution #3
Download and install the latest GFI FaxMaker Client, which should include signed drivers. Keep in mind that some earlier versions of the GFI FaxMaker Client did not include "signed drivers".