Overview
When the Archive to Database option stops working, GFI FaxMaker's reporting data also cease to update. This article outlines the steps on how to re-enable the Archive to Database option.
Environment
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GFI FaxMaker
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All supported environments
Root Causes
The issue can occur due to either one of the following reasons:
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The Archive database has reached its maximum size.
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There has been a prolonged gap in communication with the Archive database.
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The Archive database's table structure has been manually amended (i.e., adding or removing fields/columns).
Note: If the reporting database becomes corrupt, you might encounter the same problem/symptoms.
Resolution
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Verify if the table structure of the Archive database has been modified.
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Check if the communication with the Archive database has been established:
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Navigate to GFI FaxMaker and go to Configuration > Archiving Node > Properties.
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Select the Archive to Database tab and click the Setup database option. Review the database configuration and select the Test option.
Note: If Microsoft SQL is in use and the test fails, please ensure that you perform a successful ODBC test.
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If the Database Communication test is successful:
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Navigate to the archive folder in Windows Explorer using the path:
..GFI\FaxMaker\archive
and review the dlefmcache..chc files. -
If the dlefmcache..chc files are slightly larger than 156 KB in size, and database connection has been re-established, you may want to wait for a few minutes to see if these sizes reduce. If the files are substantially larger than 156 KB (or the files do not reduce in size after re-establishing the connection to the Archive database), it may be necessary to implement the new dlefmcache..chc files from a clean install version of GFI FaxMaker.
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Alternative Solution
Archiving and reporting are closely related. If there is an issue with the Archive database, it can mirror the same symptoms in case there is an archiving issue. The Archive database is a Firebird database where corruption is possible (just like with other databases). Note: The following steps will recreate the Reporting database. GFI FaxMaker's reporting will reset from the date of the procedure's implementation and will proceed prospectively. All historical data will no longer be available in the WebUI Reporting area.
To recreate GFI FaxMaker's Reporting database:
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