Overview
When sending a fax with a Microsoft Word document as an attachment, after a while the error Attachment conversion failed is returned This article gives solutions to use when sending Microsoft Word or Excel documents to FaxMaker result in Error: Attachment conversion failed: 1701.
Diagnosis
The following error is given after a 5-minute document conversion timeout:
Error: '1701: Document Conversion Timeout.
Ensure that the FaxMaker printer driver on the server machine is installed on the GFIFAX port and is set up as the default printer. Check that the application program is installed on the server and that there is an association to print with the files.'
Solution
The solution listed below is to install Microsoft Office on the FaxMaker server. The items that follow, installing the correct version and disabling protected view, are also required for the correct conversion of Microsoft Office files when sent as attachments.
Ensure Microsoft Office is installed on the FaxMaker server
By default, FaxMaker can convert the following file types:
- HTML
- PNG
- GIF
- JPG
- RTF
- TXT
In the FaxMaker Configuration > expand Advanced > Document conversion > properties, any file type listed here needs a program that can open the attachment file to be installed on the server. In the list below we see Microsoft Office files by default. Having Microsoft Office installed and activated ensures the Office files can be converted.
Correct version of Microsoft Office
Ensure the version of Microsoft Office installed on the FaxMaker server is as new or newer than the version that created the files to be converted. Example: User A creates a file on their desktop machine using Office version 2016. User A then sends the file as an attachment to the FaxMaker server for conversion. The version of Office installed on the FaxMaker server should be 2016 or newer.
Older versions of Microsoft Office may not be able to take advantage of the newer features in the newer versions and can sometimes have an issue opening the file. When the file cannot be opened, the document conversion timeout will happen.
Disable Protected View in Microsoft Office
When an Office document is opened and protected view is enabled, no actions can be taken on the document until it is disabled by selecting Enable editing from the message bar.
Since FaxMaker opens Microsoft Office documents in the background and attempts to print them, this cannot be done while protected view is active, and therefore must be disabled.
From Microsoft Word:
- Select File > Options
- Click Trust Center > Trust Center Settings > Protected View
- Deselect the options on the protected view page and select OK
Confirmation
Once the above steps have been taken, a fax sent with a Microsoft Office document as an attachment will no longer give the 1701: Attachment Conversion Error.