Overview
You may find sending faxes from email results in the fax failing. This failure could be an Unknown Error, a No Dialtone Error or a No Answer From Remote Machine Error. You will also find that sending from another sending method, like an API, Form or the line test, successfully sends the fax. This article provides the next steps to take if this happens.
Diagnosis
This has been seen with a FoIP device, like the Brooktrout SR140 or XCAPI.
Verify that faxes sent via email fail with a transmission error, usually, one listed in the Overview section of this article.
Also, verify that a test fax sent from the line test in the FaxMaker Configuration results in a successful transmission. Follow the steps below to verify this:
- From Programs, open the FaxMaker Configuration
- From the left pane, select Lines/Devices and from the right pane select properties
- Select the line you would like to use and select properties
- Select the Line test tab and enter the Fax number to dial:
- Before selecting the Send test fax button, open the FaxMaker Monitor to review the fax status as the test faxes are not logged in the sendlog.
- Once the number has been entered, select Send test fax.
- Verify the fax was sent successfully by reviewing the transmission in the FaxMaker Monitor
If the test fax from the line test was sent successfully, follow the steps in the solution.
If the test fax fails as well, verify the type of failure and proceed with troubleshooting that failure type. There are articles listed below to assist:
- Handshaking failures
- Busy tone failures
- Call failed failures
- No dialtone failures
- Unknown errors
- Faxes to specific numbers
Solution
FaxMaker by default will pull information from the fax number field in active directory for the sending user and use that is the CLIP (Calling Line Identity Presentation) or caller ID. This can negatively impact FoIP communication, for more information, see this article about customizing the CLIP and TSID, and should be disabled. Follow the steps below:
- Right-click the Start button and Run
- Type Regedit and select OK
- Navigate to the following key according to the version you are using:
- GFI FaxMaker (32 bit) : HKEY_LOCAL_MACHINE\SOFTWARE\GFI Fax & Voice\FaxMaker\Config
- GFI FaxMaker (64 bit) : HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\GFI Fax & Voice\FaxMaker\Config
- Create the DWORD value in this location called UseSenderFaxNumber and set the value to 0
With the registry key not created, the default value is 1 - Close the registry editor
- Restart the FaxMaker Fax Server service
-
- Right-click the Start button and Run
- Type services.msc and select OK
- Navigate to the FaxMaker Fax Server service > right-click and select restart
Confirmation
Once the outbound CLIP has been disabled, and the Fax Server service restarted, a test fax from email should successfully be transmitted to a recipient.