Overview
When selecting recipients in the FaxMaker Web Client, you may find that Outlook and Exchange contacts are not visible. This article provides steps to take to resolve this issue.
Environment
Any FaxMaker installation in a Microsoft Exchange environment.
Solution
Diagnosis
This issue has been seen after upgrading to Exchange 2019 and has to do with TLS connections. The errors indicate a TLS communication issue between the FaxMaker and Exchange servers. The following log excerpts can be seen as well in the AddressBook.Exchange.log.txt file located in the C:\Program Files (x86)\GFI\FaxMaker\logs folder by default.
2020-09-21,10: 32: 00,215,1, "# 000019D0", "# 00000015", "error", "AddressBook.Exchange", "ERROR: GFI.FaxMaker.AddressBook.Exchange.AddressBook :: ListPersonalAddressBook: Microsoft.Exchange.WebServices.Data.ServiceRequestException: The request failed. The underlying connection was closed: Unexpected error while sending .. ---> System.Net.WebException: The underlying connection was closed: Unexpected error while sending .. ---> System.IO.IOException: No data can be read from the transmission connection: An existing connection was closed by the remote host. ---> System.Net.Sockets.SocketException: An existing connection was closed by the remote host
Solution Steps
Open Windows Powershell on the FaxMaker server (right-click start and select Windows Powershell) and run the following commands:
New-ItemProperty -path 'HKLM:\SOFTWARE\Microsoft\.NetFramework\v4.0.30319' -name 'SchUseStrongCrypto' -value '1' -PropertyType 'DWord' -Force | Out-Null
New-ItemProperty -path 'HKLM:\SOFTWARE\WOW6432Node\Microsoft\.NetFramework\v4.0.30319' -name 'SchUseStrongCrypto' -value '1' -PropertyType 'DWord' -Force | Out-Null
New-ItemProperty -path 'HKLM:\SOFTWARE\Microsoft\.NetFramework\v4.0.30319' -name 'SystemDefaultTlsVersions' -value '1' -PropertyType 'DWord' -Force | Out-Null
New-ItemProperty -path 'HKLM:\SOFTWARE\WOW6432Node\Microsoft\.NetFramework\v4.0.30319' -name 'SystemDefaultTlsVersions' -value '1' -PropertyType 'DWord' -Force | Out-Null
Reboot the FaxMaker server and test again.
Confirmation
After adding the registry keys listed above, the Exchange/Outlook contacts will be visible in the FaxMaker Web Client.